1051-455-20073, Physical Optics

1 LAB #1 — 1-D and 2-D HARMONIC OSCILLATIONS

1.1 Rationale:

This laboratory (really a virtual lab based on computer software) introduces the concepts of harmonic
oscillations and the effects that result when multiple harmonic oscillations are superposed (added) in
one and two dimensions. The 1-D case illustrates concepts that are relevant to temporal and spatial
coherence, diffraction, and interference of electromagnetic radiation, though these more advanced
applications will not be considered until later in the course. The 2-D case is a generalization of
the description of oscillations using complex notation; z = a + b, where [a, b] are real numbers and
i=+—1.

A “harmonic” oscillation is composed of a single sinusoidal frequency. Projections of 2-D har-
monic oscillatory motion onto any radial line through the origin in the 2-D plane yields examples
of 1-D harmonic oscillatory motion which all have the same frequency and amplitude, and with the
initial phase determined by the particular axis chosen.

1.2 Preparation:

1. Write the general equation for a simple harmonic oscillation in trigonometric form (i.e., as a
function of the trigonometric functions sine, cosine, etc.).

2. Draw a diagram of the motion of a harmonic oscillator as a function of time, including a graph
of the output as a function of time. Designate on the drawings the amplitude, period, angular
frequency, phase angle, and initial phase, and specify the units for each.

1.3 Equipment:

1. Personal Computer running Windows

2. Java Program “Signals.JAR” (installed on laboratory computers) (the Java virtual machine
must be installed, which is available from
http://www.java.com/en/download.index.jsp)

3. “Audacity. EXE” (available free for IBM-compatible PCs, Mac OS X, and Linux at
http://audacity.sourceforge.net/download/)

1.4 Procedure:

The lab is based on a program written in Java by Juliet Bernstein, an undergraduate student in
the Chester F. Carlson Center for Imaging Science. It allows sinusoidal functions to be added and
displayed dynamically. The graphics screens may be grabbed as ".png" or ".jpg" files and pasted
into application programs (such as WORD™™ or POWERPOINT?™) for lab reports.

1.4.1 Summation of 1-D oscillations

The summation of same-frequency and different-frequency oscillations will be investigated. To run
the program:

1. Start the program by double-clicking on the desktop icon, which should be located in a desktop
folder named “455 Optics Labs.”

2. Click on the “lab” tab and select "Physical Optics Lab 1;" you will see this screen:
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Opening page of Lab in “Signals.jar”

3. Select the parameters for the two functions: the amplitude A,, the (approximate) period
T, in seconds (or the temporal frequency v, in Hz or the angular temporal frequency w in
radians ) ©and the initial phase ¢, (in degrees or in units of 7 radians). Note that the values
may be negative. Whenever you change a parameter, be SURE to hit the “APPLY
PARAMETERS” button in the bottom right.

t
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4. Select the option for “parallel view where the oscillations are added in the same direction.

5. Set the temporal period of the two oscillations to be T3 = T5 = 1s and the amplitudes to
be identically A; = As = 1 and the initial phase ¢; = ¢ = 0. Watch the show and use the
stopwatch to measure the actual period. The “Pause” button (|ﬂ|)stops the motion, which
may be restarted by pushing “Play” (E)

Repeat for Ty =T = 2s
Repeat for T =15 = 3s
Repeat for Ty =T = 4s
Repeat for Ty =15 =55
Repeat for T =15 = 10s

Plot the relationship between the selected and measured temporal periods. Perform a
linear regression to fit a line to the data; this may be done in a spreadsheet program like
Excel. Record the correlation coefficient of the linear regression. Plot the regression line
along with the data.

The graphics screen obtained after summing two oscillations is shown below: the input oscillations
are shown in the first two rows and the superposition in the third row.
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Observations:

1.

Add two waves in parallel with the same angular frequency w [ra‘:%}, different amplitudes

A; and Ay (both A, < 1) and different initial phases ¢, and ¢,. Measure the amplitude A
and angular frequency w of the resultant and compare to the relationship derived in class.

. Repeat #2 for several different pairs of amplitudes and initial phases. Use to confirm the

relationship for the sum of two same-frequency sinusoids with different amplitudes and phases.

Add two waves with the same amplitude A; = Ay and similar (but not identical) angular
frequencies wy and ws. The resultant amplitude oscillates as a function of time in a compli-
cated motion that actually is the sum of a rapidly varying term and a slowly varying term.
Measure both temporal periods and compute the frequencies. This illustrates the important
and common phenomenon of “BEATS”, which appear in may areas of science.

|
1.4.2 Summation of 1-D oscillations using AUDACITY.EXE Ei?

This is a simple demonstration of the summation of two waves to produce “beats.” Open the program
by double-clicking on the icon in the folder labeled “455 Optics Labs” or by using the Start button.

1.

3.
4.

From the “Project” menu, pull down the option “new Audio Track.” You can delete the track
by clicking on the “X” in the upper-left corner. Note that you must STOP playing a track
by pressing the stop button () before you can do any analysis (pressing the PAUSE button
1] is not sufficient)

. From the “Generate” menu, pull down the option “Tone.” The default is 440 Hz (the musical

note “A” — the standard note for tuning instruments). Select an amplitude of 0.5, to prevent
saturation when a second waveform of that amplitude is added. Play the tone by clicking on
the green triangle just below the “Generate” menu.

From the “Project” menu, open a second audio track.”

"From the “Generate” menu, load a sine wave with a frequency of 441 Hz.



10.

Click on the “Play” button to play both tones simultaneously. What do you hear? Use a
stopwatch to measure the period of the beat.

Examine the two individual waves by clicking on the magnifier to expand the scale.

Add the two waves:

(a) “Select all” in the “Edit” menu

(b) Select “Quick Mix” in the “Project” menu. This creates a single track that is the sum of
both tracks

(¢) Expand the scale using the “Magnify” tool to examine the waveform.

Select a section of the sum waveform (say, about 5s long) and choose “Plot Spectrum” from
the “View” menu; this evaluates the fast Fourier transform of the selection and displays the
spectrum, which is just the representation of the signal in terms of the amplitude A at each
temporal frequency v instead of in terms of the amplitude A at each time ¢. Since a true
undistorted sinusoid f [t] = Ag cos [2mvpt] is composed of only a single sinusoidal frequency vy,
the ideal representation of its spectrum is a single “spike” with amplitude Aj at the temporal
frequency v = vy.

Open a new track and generate a square wave of some base frequency. Listen to the tone and
examine the spectrum. Describe the “quality” of the tone compared to the sinusoidal function.

Open a new track and generate “white noise;” listen to the signal and plot the spectrum. This
should demonstrate why the noise is called “white.”

1.4.3 Summation of Orthogonal 1-D oscillations using Signals

The summation of two orthogonal oscillations results in a Lissajou figure, which also is called
an Argand diagram when imaginary numbers are plotted on the vertical axis. The two selected
oscillations generate the resulting motion, but the system can considered in the other direction
where the projections of the resulting motion along the z- and y-axis are the selected oscillations.

The graphics screen resulted from summation of two oscillations with the same angular frequency
w and amplitude A, but whose initial phases differed by —7 radians.
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1.

Orthogonally add pairs of oscillations to produce: linear vibration along the diagonal, circular
motion in both the clockwise and counterclockwise directions, and elliptical motion where the
major axis lies along one of the Cartesian axes (z or y), and an ellipse whose major axis is at
another angle.

. Change the periods to generate other kinds of figures; record by using the screen shot icon

(81,

If the two oscillations have the same frequency, but arbitrary amplitude and initial phase, what
can you say about the result?

1.4.4 Summation of Arbitrary Orthogonal 1-D Functions using SIGNALS

1.

First, replicate one of the cases already considered in the orthogonal summation by clicking
on the “FUNCTION” menu and selecting ”CREATE NEW FUNCTION” and “REAL and
IMAGINARY PARTS” (you can get there via “CTRL-F”)

(a) Under ”CREATE REAL PART,” select “MORE” and a COSINE wave with a long period
(say 128 samples in an array of size N = 256)

(b) Under “CREATE IMAGINARY PART,” select “MORE” and a COSINE wave with the
same period and initial phase ¢ = —90°

Display the function in the PLOT Menu as CUSTOM plots of the real+imaginary parts,
magnitude+unwrapped phase, and as ARGAND diagram.

Reenter the arrays but change the initial phase of the imaginary part to a cosine wave with
¢o = +90°. What is the difference in the displayed Argand diagram?

(a) We speak of the rate of change of the phase angle of the display as the frequency of
the complex function. In this example, the rate of change of phase is constant, so the
frequency is fixed.

Reenter the arrays but change the initial phase of the COSINE in the imaginary part to
¢o = +45°. What is the difference in the displayed Argand diagram?

Enter and view the new functions as real-imaginary parts, as magnitude/phase and as the
ARGAND diagram.

(a) REAL Part: COSINE with period = 64, amplitude = 1, center pixel = 0, initial phase
= 0: IMAGINARY Part: COSINE with period = 64, amplitude = %, center pixel = 0,
and initial phase = —90° = — 7 radians.

(b) REAL Part: COSINE with period = 64, amplitude = 1, center pixel = 0, initial phase
= 0: IMAGINARY Part: COSINE with period = 48, amplitude = 1, center pixel = 0,

and initial phase = —90° = —7 radians.

(¢) REAL Part: COSINE with period = 64, amplitude = 1, center pixel = 0, initial phase
= 0: IMAGINARY Part: COSINE with period = 64, amplitude = 1, center pixel = 0,

and initial phase = —45° = —7 radians.

(d) REAL Part: COSINE with period = 64, amplitude = 1, center pixel = 0, initial phase
= 0, IMAGINARY Part: COSINE with period = 64, amplitude = 1, center pixel = 0,
3

and initial phase = —135° = — 47 radians.

(e) REAL Part: CHIRP function with period = 64, amplitude = 1, center pixel = 0, and ini-
tial phase = 0, IMAGINARY Part: CHIRP with period = 64, amplitude = 1, center pixel

= 0, and initial phase = —90° = —7 radians. What is different about the “frequency” of
this function compared to that where the REAL and IMAGINARY parts are sinusoidal
functions?



6. Repeat the procedure for a few other functions (your choice). For example, enter sinusoids of

equal amplitudes and a phase difference of +90°, and modulate the function by multiplying
the entire function by a decaying function such as a negative exponential. View the Argand
diagram (option “N” in the “PLOT” menu).

1.4.5 Nonlinear Operations on Sinusoidal Waves

In all of the steps thus far, the output has been the a single wave or the summation of two or more
sinusoidal waves. In this section, we briefly consider the result of a specific “nonlinear” operation
on a wave.

1.

1.5

Enter a “bipolar” sinuoidal function into one of the arrays (“bipolar” means that the function
has positive and negative amplitudes), e.g., f [n] = cos [27r XLD} ; this function oscillates between

amplitudes of +1 and its average amplitude is 0. This function may be written in the complex

form:
1l = Sewli- ()] + hew [ (22 )]

= S expli- (2n (+6,) 2)] + 5 expli- (27 (~6,) )]

where &, = (Xo)™" and i = \/—1. We say that this sinusoid is the sum of two complex
sinusoids: one with spatial frequency +&, and one with frequency —¢,.

. Now plot the square of f [n]. You can do this by duplicating the array (in the operations menu

obtained via CTRL-O) and then multiplying them together (again in the operations menu).
(f [])* = (cos [2m€pa])?

but we can rewrite this using the well-known identity:

(cos[f])?® = (1 4 cos [26])

[T Y

—  (cos[2n&,z])” = %(1 + cos [2 - 27 yx])

(cos [2m€yz]) + %Cos 27 (2 &) ]

s (; exp i~ (2 (+260) 2)] + 3 expli - (2 (~26,) wﬂ)

— N = N

1 ) 1 .
= el (27 (+260) )] + g expli- (27 (~26) @)
This is composed of a cosine with infinite period and amplitude % and two complex-valued
sinusoids that oscillate with frequencies £2 - £, with amplitude i. In words, the nonlinear
operation has “created” some different spatial frequencies. This did not happen if signals were
just added together.

Questions:

. Consider two travelling waves:

2
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Find an expression for the sum of the two waves and sketch it as a function of x in the interval

—3\1 < x < 3\ for times t = 0, i, ,}1, and % Label the zero crossings, i.e., the coordinates

x where the wave has zero amplitude.



2. Repeat question 1 for the two waves:
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3. Explain the difference in tone “quality” in Audacity between the sine and square waves.



